Doing this has made me pause and think when it comes to writing down names like: MvxBindableLinearLayout
These names seem overly verbose... e.g. wouldn't MvxLinearLayout do just as well?
Some of the names are unavoidable - e.g. MvxBindingTouchTableViewController inherits from MvxTouchTableViewController - but even these could be shortened to remove the Touch part of the name (the namespace already gives us that).
And then... of course... another question is whether Mvx should stay in place as a prefix? It is useful in places to know when you are using an MvvmCross class... but it's not very pretty and can make the code less readable.
There's nothing planned on this in the very short term, but what do people think?
- Should we go on a big clean through the naming?
- Should we try to shorten some names?
- Should we try to remove the Mvx prefix?
- Should we just focus on getting more code and better code (e.g. tests) in place?
P.S. The main class name which made me pause and think on this topic was MvxActionBasedBindableTableViewSource - it's a good descriptive name, but something like MvxFuncTableViewSource might be easier on the eye ?